Rebuild #5: eXtreme Performance (Parte 3 – Surpresa indesejada)

No terceiro episódio da quinta temporada da série Rebuild, o glorioso PC com o Athlon XP será configurado e passará pela tradicional bateria de benchmarks do blog, que, porém, reservou uma indesejada surpresa. Veja no que deu! 😲


Antes de prosseguir, vale a pena conferir a configuração completa e a montagem do PC eXtreme Performance. Isto posto, vamos lá!

Definindo as partições

Com a ajuda do inestimável Super Fdisk, criei as partições no disco rígido Samsung SpinPoint de 80 GB:


Como será utilizado o Windows 98 SE juntamente com o XP, optei por usar partições FAT32 para que ambos os sistemas possam acessar as mesmas.


Configurando o hardware

Com os sistemas operacionais instalados, é hora de instalar os drivers. O primeiro deles são os drivers para o chipset Via KT400:


Seguindo-se pelos drivers da Nvidia:



Tudo configurado!


Com o CPU-Z é possível ver mais detalhes de certos componentes, como o processador, RAM e placa-mãe.





Benchmarks

3DMark 2000

A demo Nature do 3DMark 2001 SE sempre foi exigente por implementar o Pixel Shader. Agora não é mais um problema...


Como a série GeForce FX é a primeira com suporte ao DirectX 9 da Nvidia, acrescentei também o 3DMark 03:


Todos os resultados podem ser vistos abaixo. Vale destacar que neste PC não executei os antigos benchmarks e jogos para MS-DOS, pois os mesmos não trazem mais resultados representativos em máquinas desta classe.

Teste Resultado
Super PI (Segundos) 67
Quake (Demo 2 – 320 X 240 – FPS) 267,3
GLQuake (Demo 2 – 640 X 480 – FPS) 544,6
3DMark 99 Max (Score) 6141
3DMark 99 Max CPU (Score) 31239
3DMark 2000 (Score) 10650
Sandra 99 CPU (MIPS) 6152
Sandra 99 FPU (MFLOPS) 2403
Sandra 99 Memory Bandwidth (MB/s) 752
Sandra 99 Drive Benchmark (Score) 29307
Quake II OpenGL (Demo 2 – 640 X 480 – FPS) 374,3
Quake III OpenGL (Demo 2 – 640 X 480 – FPS) 186
Unreal Tournament 99 OpenGL (City intro – 640 X 480 – FPS) 113,6
3DMark 2001 SE (Score) 10597
Unreal Tournament 2003 (Flyby – 800 X 600 – FPS) 135,0
Unreal Tournament 2003 (Botmatch – 800 X 600 – FPS) 51,6

Como é possível observar na página de benchmarks clássicos, o conjunto com o Athlon XP 2200+ e a GeForce FX 5900 levou os números a um novo nível! Pena que nem tudo foi como eu esperava.

O problema e tentativas de solução

Em qualquer teste do 3DMark 03 ocorre o mostrado na imagem abaixo, o PC trava e a tela fica com caracteres aleatórios:


Primeiramente tentei atualizar os drivers da Via e da Nvidia para versões mais recentes, sem sucesso. 

Abrindo o Setup da Asus A7V8X-X, notei que o parâmetro AGP Capability fica travado no modo 8X (que é oficialmente suportado pela FX 5900): quem viveu no auge do AGP sabe que reduzir o modo de transferência para 4X resolve a maioria dos problemas, e sem um impacto notável na performance.

Pensando ser algum bug do Setup, baixei a última versão da BIOS no site da Asus e procedi com a atualização:


Infelizmente não funcionou: o AGP Capability continuou bloqueado em 8X e o 3DMark 03 continuou travando. Não há jumpers na placa-mãe para alterar o modo AGP manualmente e desabilitar os parâmetros AGP Performance Control e AGP Fast Write Control também não deram resultado. Troquei também o módulo de memória e nada feito. 😩

Por fim, imaginando que pudesse ser algum problema de compatibilidade de drivers com o Windows XP, instalei o DirectX 9 no 98 SE, porém o 3DMark 03 não é compatível com o antigo Windows. Duh.


Termino assim em um impasse. Eu realmente não queria trocar a GeForce FX 5900 pois este projeto tem a “cara” dela, assim farei uma última tentativa com outra placa-mãe de características parecidas com as da Asus A7V8X-X, de modo a não descaracterizar a série. Vamos ver o que consigo arrumar.

Comentários

  1. Será que não é memória defeituosa na FX 5900?

    ResponderExcluir
    Respostas
    1. Tudo é possível. Pode ser também a GPU e/ou a solda, ou uma incompatibilidade com a placa-mãe e chipset.

      Excluir
    2. Michael, Eu tive um problema parecido com uma M810 + Radeon 9250 com o AGP em 4X. so funcionava em AGP 2x, eu Contornei esse problema com o Riva Tuner, na versão que usava tinha opção para colocar 2x,4x,8x, nesse caso ele sempre tinha que iniciar com Windows, imagino que possa ser útil para vc testar ai. ABS

      https://www.boadica.com.br/dica/375/imaginesdica/riva_2-1.gif

      Excluir
    3. Fiz o teste. Na A7V8X-X o Riva Tuner consegue reduzir até o AGP 4X apenas, porém mesmo assim a FX 5900 continuou com o mesmo problema. :-(

      Excluir
  2. Se quiser tentar rodar o 3dmark03 no windows98 instale a versão (3dmark03_340), versão 360 não roda no windows98.

    http://dl.4players.de/f1/3DMark/3dmark03_340.exe

    Sabe dizer se a FX funcionou perfeitamente em outra placa mãe?
    Se possível rode algum game DX9 pra ver se da algum erro parecido com o do 3dmark03.

    Abs.

    ResponderExcluir
    Respostas
    1. Até o momento não consegui testar em outra placa-mãe, vou testar no Windows 98. Obrigado!

      Ainda não consegui reproduzir a falha em outra aplicação, porém se o problema for apenas no 3DMark 03 dá para aproveitar a FX 5900 em outro projeto.


      Excluir
    2. Acabei de testar no Windows 98, foi o mesmo problema. Acho que a valente FX 5900 realmente não está 100%.

      Mas não desistirei dela ainda, vou buscar uma outra placa-mãe para testar.

      Excluir
    3. Poxa que pena, testar em outra placa mãe seria excelente para tirar essa dúvida.

      Excluir

Postar um comentário